Please login or register. June 19, 2021, 03:13:24 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - miro

Pages: 1 2 [3] 4 5 6
31
How To / Re: CD Editor Export
« on: June 09, 2012, 07:37:13 PM »
Hi Jim,

Thanks for extensive testing and possible workarounds. Can you give image of those Cds you are trying to export for download? It will certainly help me to resolve the issue. It sounds like the block size is different. Just make an iso image.

Thx in advance

Miro

Ps: i am happy it sounds well.

32
General Discussion / Re: Goodmorning Roland friends!
« on: June 08, 2012, 02:34:29 PM »
Cool gear  :) and welcome here.

33
How To / Re: CD Editor Export
« on: June 08, 2012, 02:31:26 PM »
Hi Jim,

thanks for an example. In the meanwhile, I have found a bug in downmixing routine in SMFW30 Tone Editor which can cause this sound degradation. I will correct this asap. Actual export of diskimage from CD is done without any changes. I just dump binary region which is belonging to the area on the CD. So this problem is in the wave export of SMFW30. Otherwise if you can provide me the CD image I can investigate further.

I will keep you posted.

Miro

34
News / Re: Sound repository
« on: May 05, 2012, 01:23:10 AM »
Hi Nick,

thats great news. I will pm or mail you some place to upload the stuff and we'll see where it will lead us ;).

cheers

Miro

35
General Discussion / Re: Roland W-30 Hardware problems
« on: May 05, 2012, 01:21:27 AM »
Hi Nick,

actually I have similar problem with keys only that in my case it is just 3 of them. Actually I have recently cleaned whole thing and used a tip of another Roland user found on the web. Just take off rubber from under the keys and then use pencil eraser to clean the contacts  ::). One way or another it really helps but one of the keys is still not working reliably. One of the rubbers is broken so I am accounting it to that.

cheers

Miro

36
How To / Re: CD Editor Export
« on: February 28, 2012, 12:26:29 AM »
cool Jim, nice workaround. Are you sure you have used current version of SMFW30 to read the CD? I have completely rewritten CD editor to use SPTI instead of ASPI. On Win 7 it should work without any major troubles. Maybe you can switch on the compatibility mode with Win XP SP3 if you are experiencing troubles. Anyway if you cannot get it working I can pm you my skype handle and we can do live troubleshooting session  ;D.

On the other hand, I was having a hard time lately. My W30 gave it up and it took me more then a month to get it working again. Some sort or contact issue, display goes wacko and all leds are blinking randomly. After I have reassembled the damn thing some 10 times it worked again. Unfortunately my cursor dial is broken. So I have to get a new one. However it makes the W30 unusable because some parameters cannot be accessed and I cannot test  >:(. I hope to get the dial fixed asap so I can resume my tests.

37
General Discussion / Re: How to Set Up Roland W30 Without Floppy Drive?
« on: August 11, 2011, 08:47:11 AM »
That is nice to hear :). I think we should put detailed how-to section with our experiences. Maybe here on the forum?

38
General Discussion / Re: How to Set Up Roland W30 Without Floppy Drive?
« on: August 02, 2011, 09:11:09 PM »
Hi Drew,

I am on the quest for the best replacement of floppy for W30 already long time. Currently I am using HXC floppy emulator http://hxc2001.free.fr/ and SCSI hdd when necessary. To sum it up SCSI stuff cannot be easily built into the W30 and I like my stuff neat  ;D. For the moment HXC2001 is probaly easiest option to go with. Here are some pics of my attempt to put it inside of W30:

my W30 disassembled
W30 floppy holder chassis
HxC in W30
HxC in W30 - closeup
HxC built in W30
HxC built in W30 - closeup

It is not yet perfect but you get an idea. I am planning to make a benchmark between SCSI and floppy emul. In the span of time I plan to add support for HFE images in SMFW30. If I will have really veeery much spare time (very improbable but one never know) I want to build project of Michael Bauerle (http://micha.freeshell.org/pcmcia_drive/index.php). If W30 can boot from this device I will probably try to place it somehow inside.

regards

Miro

39
News / Update for Tone Editor
« on: June 14, 2011, 12:22:44 PM »
Hey guys,

I spared some time and there will be an update to Tone Editor soon. Features added are:

  • playing samples right in Tone Editor
    This is a tricky one  ;) we are speaking here about raw samples only. No envelopes, filters or whatsoever Roland does. Main purpose of this is looping.
  • Create subtone
    add subtone on any existing tone and then edit its parameters

Update will be available through Live Updater.
let me know what do you think about it.

regards

Miro


40
General Discussion / Re: BLOG ABOUT W30
« on: June 07, 2011, 08:48:56 AM »
Hi Ana,

thanks for your blog, nice addition to the info about W30 ;). I will also create some links section for this purpose on smfw30 website.

regards

Miro

41
Bugs / Re: SMFW30 2.1.0.0 Technical Difficulties
« on: May 26, 2011, 09:49:03 PM »
Hi Nick,

no problem just send me the diskimage and tell me which song it is. I will take a look, well because there is no documentation :o on Roland Song format I can just do try and fail reverse engineering so this kind of things can happen. Just mail it  ;)

cheers

Miro

42
Bugs / Re: SMFW30 2.1.0.0 Technical Difficulties
« on: May 25, 2011, 02:52:04 PM »
Hi Jim,

thanks for your lightning fast reply 8). And now issues:

 
Quote
1.  In the Tone Editor under the Loop Mode Pull Down Menu there is a spelling error.  Fordward should be "Forward".
  yes this is a spelling mistake, sorry but english is not my native language  :-[ so have some patience with me  ;)

 
Quote
2.  Everything in the Tone Editor appears to work with the exception of playing sounds.  The play button is grayed out.
       The Tone Editor is fantastic but it might be difficult without a method for "auditioning" the sound especially when
       checking the loop points and envelopes.
  this is true, audition is not yet enabled. I will try to push this as one of the first updates. However this will play just a raw sample without
  the envelope and filters which of course are happenning in W30. Of course wish of the users is the most important.

 
Quote
3.  The Patch Editor appears to be view only with no editing ability or way to create new patches.
      Other than having a glimpse of the patch parameters I'm not sure how useful this will be.
      I'm guessing this is under development still.
      well Jim you are partially right. Patch editor is new written from scratch so I focused on common CRUD functionality, no parameters editing for the moment. However there is possibility to load patch and match with another subtones to fastly create new patches. I will write how to on this.

As I stated in my previous post it is not yet finished, but because of so many changes which has been introduced against the previous version I have released this new package. Because of internet updater which is bundled now I can push more local updates for Tone or Patch editor and people dont have to anymore reinstall whole thing. Now I want also gather necessary feedback from users so we can set the goals what are the most used and needed features and also workflows.

cheers

Miro

43
News / SMFW30 2.1.0.0 is out
« on: May 25, 2011, 12:41:33 AM »
Hey guys,

thank you all for the patience, new site with SMFW30 v2.1.0.0 is out :o. There is several improvements as described in my previous posts. However it is not perfect yet. I would like to hear from you what you find good and bad so we can further improve it. If the time allows I will try to create instructional video and upload it to the site. Lot of help topics will come on site as well look at it as on work in progress.

cheers

Miro

44
News / Re: FINAL BETATEST!!!
« on: May 17, 2011, 09:07:41 AM »
Update:

bugs in the MIDI editor were related to deleted files :o which were not hidden. This I have corrected yesterday. New site is designed I am now filling some content, with a bit of luck I will be done this week.

45
News / Re: FINAL BETATEST!!!
« on: May 14, 2011, 10:38:31 AM »
Hey guys,

thanks to whole diskimage library Paolo sent me, I have found still some bugs in MIDI editor so now checking the extent of it. If its small I will still correct it otherwise there will be patch later. Recently I have added integration with Windows. So now you can just double-click diskimage and it will depending on type directly open in Tone or MIDI editor.

hopefully I will be done soon  :)

Pages: 1 2 [3] 4 5 6