Please login or register. June 19, 2021, 03:25:51 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - miro

Pages: 1 [2] 3 4 ... 6
16
Bugs / Re: "Unknown MIDI event found"
« on: February 01, 2013, 12:39:02 PM »
Hi Paolo,

problems you are encountering are caused by damaged FAT system on the floppy you have copied. So basically on the end of the song a block couldn't be copied and SMFW30 has replaced it by zeroes. Of course my MIDI conversion logic doesn't take this situation in account and that is why you get an error. Musical event is expected and instead he gets an zero. I will implement a warning dialog with possibility to skip empty or unrecognized place until some sensible data are encountered. Though produced MIDI's will contain some malformed events which you then need to clean in the MIDI editor of your choice.

best regards

Miro

17
Bugs / Re: "Unknown MIDI event found"
« on: January 28, 2013, 12:00:06 AM »
have you used the last (1.8.0.0) version of the MIDI editor? Secondly can you send me the disk image with song in question. Also there is logging built in the SMFW30. You can switch it on in MIDI Editor by going to menu File > Preferences, tab Conversion and checking the checkbox on the bottom of dialog (Log conversion progress). Then try to export song once more and there will be file named ConversionLog-Song2MIDI.txt in the installation directory of SMFW30. Send me the log.

best regards and thanks for your appreciation (and registration)

18
News / MIDI Editor Update!!!
« on: November 21, 2012, 11:08:51 PM »
Hello guys,

I have created a bug fix update for MIDI Editor. There has been a known error in conversion when song contained Sysex event spanning over two sectors. Please use built in Online Update to get the latest version v1.8.0.0.

If you can't see versions of your SMFW30 when right clicking or clicking on About in the editors, most likely working directory is not set. To correct this, right click the SMFW30 icon, from the context menu choose Properties and fill the working directory. It should be something like C:\Program Files (x86)\Miro Svetlik\SMFW30 .

enjoy

Miro

19
News / Re: My W-30 testing New SCSI Gear
« on: October 15, 2012, 11:10:17 AM »
Cool Katsumi,

I am also dying to know whether it will boot :).

Miro

20
Bugs / Re: Same static when exporting as Ricochet
« on: October 15, 2012, 11:08:25 AM »
Hi Jim,

I know already :). After some investigation with other S-50 owners I found out that the structure of the diskimage data is totally different, so my mapping did not work. Also SMFW30 works with sort of the fingerprint system to recognize the images and in the last year I received new sorts of diskimages which I have never seen before. They are now incorporated in my working code, however I found some nasty memory leaks in the undo/redo code causing crashes you have reported to me. I would love to have this resolved before I will release next version with proper support for S-50 and new types of diskimages.

best regards

Miro

21
News / Re: My W-30 testing New SCSI Gear
« on: October 10, 2012, 10:28:36 PM »
Hi Katsumi,

that is very interesting news. :o I am really dying to know whether it will boot. I suppose it will work if you boot from floppy. I have similar device from Microtech which is working but does not boot with W30. Do I see right on the photo that it does not require external power but is fed through SCSI DB25 connector?

In any case please let us know how it went and GOOD LUCK  8)

22
News / New W30 :)
« on: August 27, 2012, 01:36:07 AM »
Yes, finally got myself a new W30  ;D. It has new display, all keys are working, well pure joy. However mainly it means I will be able to test SMFW30 on the real machine again.

see ya guys  :P

Miro

23
Bugs / Re: Same static when exporting as Ricochet
« on: August 25, 2012, 12:08:55 AM »
Hi,

here it is.

http://smfw30.svetlik.be/download/CDEd12Beta.zip

 I dont know if this forum does not keep the download history but you are right that previous file is not accessible.

Miro

24
General Discussion / Re: SMFW30 V1.0 Download location gone?
« on: August 08, 2012, 05:59:15 PM »
Hi Jason,

well normally it is not available anymore on the net because new version is superior to it. But for the convenience I have uploaded it for you in the attachment. Take care as this is the last Beta. After this I have stopped work on it and proceed with the development of modular new version.

anyway, have fun  ;)

Miro

PS: regarding the registration it is sharing the protection with current SMFW30 so it will work automatically. There is just one registration for all versions of SMFW30.

25
How To / Handy conversion script for HxC floppy emulator
« on: July 29, 2012, 02:12:09 AM »
Hello guys,

while you are waiting on direct HxC support in SMFW30, on the request of Wadge I have created small conversion script to make creation of HFE files for HxC floppy emulator easier. Here is how:

  • download my repack of HxC software v1.6.11.15 with included script from here: http://smfw30.svetlik.be/download/HxC_with_script.zip
  • extract the archive for example on your desktop (it should create a new directory "HxCFloppyEmulator_soft"
  • Open commandline by clicking on START button and typing cmd, then press enter.
  • navigate to the "HxCFloppyEmulator_soft" directory by using command cd. Easiest is type cd and then copy and paste the path to the "HxCFloppyEmulator_soft" from explorer.
  • now type convert2hfe.cmd name_of_the_diskimage.sdk where name_of_the_diskimage.sdk is the filename of diskimage you want to convert
  • script will create two subdirectories .\W30 and .\HFE in the "HxCFloppyEmulator_soft" directory. In .\HFE directory will be converted diskimage which you need to copy on the SD CARD, or script will print an error on the console window

I hope this will be useful.

best regards

Miro

26
Bugs / Re: Couldn't Allocate Memory Errors
« on: June 26, 2012, 07:53:19 PM »
Hi Jim,

this suggests a memory leak. If you can reproduce it please describe the steps and let me know. I suppose it is happening with Tone Editor but as I said give me some more information and we can track it down :).

have a good one

Miro

27
Bugs / Re: SubTones Problem in S-50
« on: June 16, 2012, 01:19:29 AM »
Hi Jim,

most likely it will be S-50 specific problem. S-50 has a gap between tones, this space is reserved for his own data. So SMFW30 leaves these untouched (zeroed) this could cause an dummy tones. Anyway could you maybe make for me a test diskimage from S-50 containing test data. This would take some work on your side but it would allow me reverse engineer the data structure. I need a you to create tone with every parameter containing another number, so there will be not two same values. Then take photos of display so I can see which values are mapped to what labels. This would help me tremendously. As I have stated before I do not own S-50 so cannot test directly, so I am glad for your input. I will check this asap. By the way did you noticed my last reply about CD Editor? (http://smfw30.svetlik.be/forum/index.php/topic,171.15.html) I have prepared a beta of new feature for you to test.

regards

Miro

28
How To / Re: CD Editor Export
« on: June 15, 2012, 10:17:02 AM »
Hi Jim,

I have played with the CD Editor a bit. Major problem is with the way my testing CD is burned I guess. I do not have any original Roland CD so my testing was done just with CD I have burned from an image. I have burned it as MODE1 CD, so there is a possibility that a real Roland CD is burned in another mode. (these modes cause different way how data is read from CD).

Do you actually have a real SCSI CD-ROM attached to the sampler? If so and you can read your CDs on your sampler, can you please check which mode are the CDs burned. If you need assistance on how just let me know.

I've put together new CD Editor beta (in the attachment of this post) with possibility to open ISO images directly from PC. Can you give it a shot and test if static is still there after export? At my side everything works smoothly (no static whatsoever). I have exported 'Harp Plucks' and 'Nylon Guitar' as diskimages and then exported tones into wavs. All perfect without glitches.

To install this beta:
  • Backup the current version of CDEd.dll (located in C:\Program Files (x86)\Miro Svetlik\SMFW30\)
  • Overwrite CDEd.dll with file in this attachment.
  • Run SMFW30 and launch CD Editor
  • Click on radio button IMAGE FILE and select iso image you have send me
  • Try to export any diskimage
  • Open diskimage in the Tone Editor and save some Tones as Waves
  • Check Waves in your default Sample Editor

thanks in advance and let me know if this worked out  ;)

cheers

Miro

29
How To / Re: CD Editor Export
« on: June 14, 2012, 11:34:26 PM »
Hi Jim,

I just found another W30 which I am going to buy so my troubles will be resolved ;-). Probably I am going to assemble one 'show model' from these two :o. By the way the whine you are talking about is one and only real annoying thing. So far as I know this is caused by the inverter of the display. Did you replace the backlight and inverter on your W30? Some guys long time ago told me that should fix the issue. I know S50 is also a cool option. If I will have some spare money, who knows :).

Miro

30
How To / Re: CD Editor Export
« on: June 10, 2012, 10:43:22 PM »
Thanks for download  ;D, unfortunately my W30 is not yet fixed. I have to find the source for the rotaty controllers which are by the display. Cannot find them anywhere near ???. But I will do some testing with your image if it is a block issue or anything else. And by the way you are definitely right about the sound of Roland samplers :) they are sweet nice to work with. I hope to get some new track soon on my soundcloud introducing some cool patches I have made some time ago. Analoguesness is just dripping from it :P.

cheers

Miro

Pages: 1 [2] 3 4 ... 6